$re = '/^.*?s(\d{2})((?:e\d{2})+)\..*/';
$str = 'showname.s01e01e02e03.extension';
$subst = "Season: $1 - Episodes: $2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;