# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?![10]*(?<!0)000(?!0)[10]*)[10]+//gm;t' <<< "100100
1000100
00100
000100
0000100
111000
11100001"