re = /^(?![10]*(?<!0)000(?!0)[10]*)[10]+/m
str = '100100
1000100
00100
000100
0000100
111000
11100001'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result