import Foundation
let pattern = #"^(?![10]*(?<!0)000(?!0)[10]*)[10]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
100100
1000100
00100
000100
0000100
111000
11100001
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)