use strict;
my $str = '100100
1000100
00100
000100
0000100
111000
11100001';
my $regex = qr/^(?![10]*(?<!0)000(?!0)[10]*)[10]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";