using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![10]*(?<!0)000(?!0)[10]*)[10]+";
string substitution = @"";
string input = @"100100
1000100
00100
000100
0000100
111000
11100001";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}