$re = '/^(?![10]*(?<!0)000(?!0)[10]*)[10]+/m';
$str = '100100
1000100
00100
000100
0000100
111000
11100001';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;