#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?![10]*(?<!0)000(?!0)[10]*)[10]+"
Local $sString = "100100 " & @CRLF & _
"1000100" & @CRLF & _
"00100" & @CRLF & _
"000100" & @CRLF & _
"0000100" & @CRLF & _
"111000" & @CRLF & _
"11100001"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)