using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{\s*([\s\S]*?)\s*}";
string input = @"<!DOCTYPE html>
<html>
<body>
<button id=""btn-get"">$.get()</button>
<script data-require=""jquery"" data-semver=""2.0.3"" src=""http://code.jquery.com/jquery-2.0.3.min.js""></script>
<script type=""text/javascript"" charset=""utf-8"">
function getValue(element)
{
alert(element);
//end
}
var content, matched;
$('#btn-get').click(function(e)
{
$.get('abc.html', function(data)
{
content = data;
});
matched = String(content).match(""getValue(.*)end"");
console.log(matched);
});
</script>
</body>
</html>
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}