const regex = /{\s*([\s\S]*?)\s*}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{\\s*([\\s\\S]*?)\\s*}', '')
const str = `<!DOCTYPE html>
<html>
<body>
<button id="btn-get">\$.get()</button>
<script data-require="jquery" data-semver="2.0.3" src="http://code.jquery.com/jquery-2.0.3.min.js"></script>
<script type="text/javascript" charset="utf-8">
function getValue(element)
{
alert(element);
//end
}
var content, matched;
\$('#btn-get').click(function(e)
{
\$.get('abc.html', function(data)
{
content = data;
});
matched = String(content).match("getValue(.*)end");
console.log(matched);
});
</script>
</body>
</html>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}