import re
regex = re.compile(r"{\s*([\s\S]*?)\s*}")
test_str = ("<!DOCTYPE html>\n"
"<html>\n"
" <body>\n"
" <button id=\"btn-get\">$.get()</button>\n"
" <script data-require=\"jquery\" data-semver=\"2.0.3\" src=\"http://code.jquery.com/jquery-2.0.3.min.js\"></script>\n"
" <script type=\"text/javascript\" charset=\"utf-8\"> \n"
" function getValue(element)\n"
" {\n"
" alert(element);\n"
" //end\n"
" }\n\n"
" var content, matched;\n"
" $('#btn-get').click(function(e) \n"
" {\n"
" $.get('abc.html', function(data) \n"
" {\n"
" content = data;\n"
" });\n"
" matched = String(content).match(\"getValue(.*)end\"); \n"
" console.log(matched);\n"
" });\n"
" </script>\n"
" </body>\n"
"</html>\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")