#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\/"
Local $sString = "/fileserver/thumbnail/THUMBNAIL.jpg" & @CRLF & _
"/img/list/btn_img02.gif" & @CRLF & _
"/img/list/cont_img06.gif" & @CRLF & _
"/img/list/line02.gif" & @CRLF & _
"/comment.asp" & @CRLF & _
"/img/foot/foot_logo.gif" & @CRLF & _
"/img/foot/btm_img01.gif" & @CRLF & _
"/img/foot/btm_img02.gif" & @CRLF & _
"/img/foot/btm_img03.gif" & @CRLF & _
"/img/list/cont_img07.gif" & @CRLF & _
"/img/list/cont_img08.gif" & @CRLF & _
"/img/list/btn_img03.gif"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")