import Foundation
let pattern = #".*\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/fileserver/thumbnail/THUMBNAIL.jpg
/img/list/btn_img02.gif
/img/list/cont_img06.gif
/img/list/line02.gif
/comment.asp
/img/foot/foot_logo.gif
/img/foot/btm_img01.gif
/img/foot/btm_img02.gif
/img/foot/btm_img03.gif
/img/list/cont_img07.gif
/img/list/cont_img08.gif
/img/list/btn_img03.gif
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)