// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*\/").unwrap();
let string = "/fileserver/thumbnail/THUMBNAIL.jpg
/img/list/btn_img02.gif
/img/list/cont_img06.gif
/img/list/line02.gif
/comment.asp
/img/foot/foot_logo.gif
/img/foot/btm_img01.gif
/img/foot/btm_img02.gif
/img/foot/btm_img03.gif
/img/list/cont_img07.gif
/img/list/cont_img08.gif
/img/list/btn_img03.gif";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}