import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\/";
final String string = "/fileserver/thumbnail/THUMBNAIL.jpg\n"
+ "/img/list/btn_img02.gif\n"
+ "/img/list/cont_img06.gif\n"
+ "/img/list/line02.gif\n"
+ "/comment.asp\n"
+ "/img/foot/foot_logo.gif\n"
+ "/img/foot/btm_img01.gif\n"
+ "/img/foot/btm_img02.gif\n"
+ "/img/foot/btm_img03.gif\n"
+ "/img/list/cont_img07.gif\n"
+ "/img/list/cont_img08.gif\n"
+ "/img/list/btn_img03.gif";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}