const regex = /.*\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\\/', 'gm')
const str = `/fileserver/thumbnail/THUMBNAIL.jpg
/img/list/btn_img02.gif
/img/list/cont_img06.gif
/img/list/line02.gif
/comment.asp
/img/foot/foot_logo.gif
/img/foot/btm_img01.gif
/img/foot/btm_img02.gif
/img/foot/btm_img03.gif
/img/list/cont_img07.gif
/img/list/cont_img08.gif
/img/list/btn_img03.gif`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}