#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(M)([0-9])$"
Local $sString = "2020M6" & @CRLF & _
"2020M10"
Local $sSubst = "\10\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)