use strict;
my $str = '2020M6
2020M10';
my $regex = qr/(M)([0-9])$/mp;
my $subst = '\\10\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";