const regex = /(M)([0-9])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(M)([0-9])$', 'gm')
const str = `2020M6
2020M10`;
const subst = `\10\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);