package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(M)([0-9])$`)
var str = `2020M6
2020M10`
var substitution = "\10\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}