$re = '/(M)([0-9])$/m';
$str = '2020M6
2020M10';
$subst = "\10\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;