# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^a-z]+[a-z]+)([^a-z]+[a-z]+)([^a-z]+[a-z]+)([^a-z]+[a-z]+)(?=[^a-z]*)$/$2$4$3$1/gm;t' <<< "modeland istoria in tiparele fluide ale artei si despre frumusetea adevarului integral"