use strict;
my $str = 'modeland istoria in tiparele fluide ale artei si despre frumusetea adevarului integral';
my $regex = qr/([^a-z]+[a-z]+)([^a-z]+[a-z]+)([^a-z]+[a-z]+)([^a-z]+[a-z]+)(?=[^a-z]*)$/mp;
my $subst = '$2$4$3$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";