using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^a-z]+[a-z]+)([^a-z]+[a-z]+)([^a-z]+[a-z]+)([^a-z]+[a-z]+)(?=[^a-z]*)$";
string substitution = @"$2$4$3$1";
string input = @"modeland istoria in tiparele fluide ale artei si despre frumusetea adevarului integral";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}