import re
regex = re.compile(r"([^a-z]+[a-z]+)([^a-z]+[a-z]+)([^a-z]+[a-z]+)([^a-z]+[a-z]+)(?=[^a-z]*)$", flags=re.MULTILINE)
test_str = "modeland istoria in tiparele fluide ale artei si despre frumusetea adevarului integral"
subst = "$2$4$3$1"
result = regex.sub(subst, test_str)
if result:
print(result)