$re = '/([^a-z]+[a-z]+)([^a-z]+[a-z]+)([^a-z]+[a-z]+)([^a-z]+[a-z]+)(?=[^a-z]*)$/m';
$str = 'modeland istoria in tiparele fluide ale artei si despre frumusetea adevarului integral';
$subst = "$2$4$3$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;