re = /([^a-z]+[a-z]+)([^a-z]+[a-z]+)([^a-z]+[a-z]+)([^a-z]+[a-z]+)(?=[^a-z]*)$/m
str = 'modeland istoria in tiparele fluide ale artei si despre frumusetea adevarului integral'
subst = '$2$4$3$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result