#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?miu)^\/[a-zа-яё0-9][-a-zа-яё0-9.]+(?:\?[а-яa-zё]+=[0-9]+|#[а-яa-zё]+)?$"
Local $sString = "/блаблабла" & @CRLF & _
"/блабла-блабла" & @CRLF & _
"/блаблабла#блаблабла" & @CRLF & _
"/блаблаблбала?ывапваып=123409008098" & @CRLF & _
"Проблема в том что оно пропускает вот это:" & @CRLF & _
"" & @CRLF & _
"/блаблаблбала?ывапваып="
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")