import re
regex = re.compile(r"^\/[a-zа-яё0-9][-a-zа-яё0-9.]+(?:\?[а-яa-zё]+=[0-9]+|#[а-яa-zё]+)?$", flags=re.MULTILINE | re.IGNORECASE | re.UNICODE)
test_str = ("/блаблабла\n"
"/блабла-блабла\n"
"/блаблабла#блаблабла\n"
"/блаблаблбала?ывапваып=123409008098\n"
"Проблема в том что оно пропускает вот это:\n\n"
"/блаблаблбала?ывапваып=")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")