import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/[a-zа-яё0-9][-a-zа-яё0-9.]+(?:\\?[а-яa-zё]+=[0-9]+|#[а-яa-zё]+)?$";
final String string = "/блаблабла\n"
+ "/блабла-блабла\n"
+ "/блаблабла#блаблабла\n"
+ "/блаблаблбала?ывапваып=123409008098\n"
+ "Проблема в том что оно пропускает вот это:\n\n"
+ "/блаблаблбала?ывапваып=";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}