using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/[a-zа-яё0-9][-a-zа-яё0-9.]+(?:\?[а-яa-zё]+=[0-9]+|#[а-яa-zё]+)?$";
string input = @"/блаблабла
/блабла-блабла
/блаблабла#блаблабла
/блаблаблбала?ывапваып=123409008098
Проблема в том что оно пропускает вот это:
/блаблаблбала?ывапваып=";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}