re = /^\/[a-zа-яё0-9][-a-zа-яё0-9.]+(?:\?[а-яa-zё]+=[0-9]+|#[а-яa-zё]+)?$/mi
str = '/блаблабла
/блабла-блабла
/блаблабла#блаблабла
/блаблаблбала?ывапваып=123409008098
Проблема в том что оно пропускает вот это:
/блаблаблбала?ывапваып='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end