use strict;
my $str = '/блаблабла
/блабла-блабла
/блаблабла#блаблабла
/блаблаблбала?ывапваып=123409008098
Проблема в том что оно пропускает вот это:
/блаблаблбала?ывапваып=';
my $regex = qr/^\/[a-zа-яё0-9][-a-zа-яё0-9.]+(?:\?[а-яa-zё]+=[0-9]+|#[а-яa-zё]+)?$/miup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}