$re = '/^\/[a-zа-яё0-9][-a-zа-яё0-9.]+(?:\?[а-яa-zё]+=[0-9]+|#[а-яa-zё]+)?$/miu';
$str = '/блаблабла
/блабла-блабла
/блаблабла#блаблабла
/блаблаблбала?ывапваып=123409008098
Проблема в том что оно пропускает вот это:
/блаблаблбала?ывапваып=';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);