#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!os\.)\bpath\b"
Local $sString = "if path and not os.path.sep in path" & @CRLF & _
"chaos.path won't match" & @CRLF & _
"but as.path will, as it checks for literal os." & @CRLF & _
"pathhello and worldpath won't match due to word boundaries" & @CRLF & _
"O'path will."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")