const regex = new RegExp('(?<!os\\.)\\bpath\\b', 'g')
const str = `if path and not os.path.sep in path
chaos.path won't match
but as.path will, as it checks for literal os.
pathhello and worldpath won't match due to word boundaries
O'path will.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}