import Foundation
let pattern = #"(?<!os\.)\bpath\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
if path and not os.path.sep in path
chaos.path won't match
but as.path will, as it checks for literal os.
pathhello and worldpath won't match due to word boundaries
O'path will.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)