import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!os\\.)\\bpath\\b";
final String string = "if path and not os.path.sep in path\n"
+ "chaos.path won't match\n"
+ "but as.path will, as it checks for literal os.\n"
+ "pathhello and worldpath won't match due to word boundaries\n"
+ "O'path will.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}