re = /(?<!os\.)\bpath\b/
str = 'if path and not os.path.sep in path
chaos.path won\'t match
but as.path will, as it checks for literal os.
pathhello and worldpath won\'t match due to word boundaries
O\'path will.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end