$re = '/(?<!os\.)\bpath\b/';
$str = 'if path and not os.path.sep in path
chaos.path won\'t match
but as.path will, as it checks for literal os.
pathhello and worldpath won\'t match due to word boundaries
O\'path will.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);