using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!os\.)\bpath\b";
string input = @"if path and not os.path.sep in path
chaos.path won't match
but as.path will, as it checks for literal os.
pathhello and worldpath won't match due to word boundaries
O'path will.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}