package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*[0-9].*[|][0-9]{2}.[0-9]{2}.[0-9]{4}.*`)
var str = `|Sort criteria|Ascdg|Descending|Subtotal|
|---------------------------------------|
|Number Group | X | | X |
|Document type| X | | X |
-----------------------------------------
---------------------------
|Data statistics|Number of|
|-------------------------|
|Records passed | 638,705|
---------------------------
----------------------
| CoCode|Prod.Month |
|---------------------
| 1002 |31.12.2020 |
| 1002 |31.12.2020 |
| 1002 |31.12.2020 |
| 1002 |31.12.2020 |
| 1002 |31.12.2020 |
----------------------
----------------------
| CoCode|Prod.Month |
|---------------------
| 1002 |31.07.2020 |
| 1002 |31.07.2020 |
| 1002 |31.07.2020 |
----------------------`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}