import re
regex = re.compile(r".*[0-9].*[|][0-9]{2}.[0-9]{2}.[0-9]{4}.*", flags=re.MULTILINE)
test_str = ("|Sort criteria|Ascdg|Descending|Subtotal|\n"
"|---------------------------------------|\n"
"|Number Group | X | | X |\n"
"|Document type| X | | X |\n"
"-----------------------------------------\n"
"---------------------------\n"
"|Data statistics|Number of|\n"
"|-------------------------|\n"
"|Records passed | 638,705|\n"
"---------------------------\n"
"----------------------\n"
"| CoCode|Prod.Month |\n"
"|---------------------\n"
"| 1002 |31.12.2020 |\n"
"| 1002 |31.12.2020 |\n"
"| 1002 |31.12.2020 |\n"
"| 1002 |31.12.2020 |\n"
"| 1002 |31.12.2020 |\n"
"----------------------\n"
"----------------------\n"
"| CoCode|Prod.Month |\n"
"|---------------------\n"
"| 1002 |31.07.2020 |\n"
"| 1002 |31.07.2020 |\n"
"| 1002 |31.07.2020 |\n"
"----------------------")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")