import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*[0-9].*[|][0-9]{2}.[0-9]{2}.[0-9]{4}.*";
final String string = "|Sort criteria|Ascdg|Descending|Subtotal|\n"
+ "|---------------------------------------|\n"
+ "|Number Group | X | | X |\n"
+ "|Document type| X | | X |\n"
+ "-----------------------------------------\n"
+ "---------------------------\n"
+ "|Data statistics|Number of|\n"
+ "|-------------------------|\n"
+ "|Records passed | 638,705|\n"
+ "---------------------------\n"
+ "----------------------\n"
+ "| CoCode|Prod.Month |\n"
+ "|---------------------\n"
+ "| 1002 |31.12.2020 |\n"
+ "| 1002 |31.12.2020 |\n"
+ "| 1002 |31.12.2020 |\n"
+ "| 1002 |31.12.2020 |\n"
+ "| 1002 |31.12.2020 |\n"
+ "----------------------\n"
+ "----------------------\n"
+ "| CoCode|Prod.Month |\n"
+ "|---------------------\n"
+ "| 1002 |31.07.2020 |\n"
+ "| 1002 |31.07.2020 |\n"
+ "| 1002 |31.07.2020 |\n"
+ "----------------------";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}