import Foundation
let pattern = #".*[0-9].*[|][0-9]{2}.[0-9]{2}.[0-9]{4}.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
|Sort criteria|Ascdg|Descending|Subtotal|
|---------------------------------------|
|Number Group | X | | X |
|Document type| X | | X |
-----------------------------------------
---------------------------
|Data statistics|Number of|
|-------------------------|
|Records passed | 638,705|
---------------------------
----------------------
| CoCode|Prod.Month |
|---------------------
| 1002 |31.12.2020 |
| 1002 |31.12.2020 |
| 1002 |31.12.2020 |
| 1002 |31.12.2020 |
| 1002 |31.12.2020 |
----------------------
----------------------
| CoCode|Prod.Month |
|---------------------
| 1002 |31.07.2020 |
| 1002 |31.07.2020 |
| 1002 |31.07.2020 |
----------------------
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)