using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m-s)(?:^(?=.*\bbar\b)|(?!^)\G).*?\K[ ]{2}";
string substitution = @"\\t";
string input = @"foo: here is some sample text
bar: here is some sample text
The closest that I've gotten has been using this:
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}