re = /(?m-s)(?:^(?=.*\bbar\b)|(?!^)\G).*?\K[ ]{2}/
str = 'foo: here is some sample text
bar: here is some sample text
The closest that I\'ve gotten has been using this:
'
subst = '\\\\t'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result