import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m-s)(?:^(?=.*\\bbar\\b)|(?!^)\\G).*?\\K[ ]{2}";
final String string = "foo: here is some sample text\n"
+ "bar: here is some sample text\n\n"
+ "The closest that I've gotten has been using this:\n";
final String subst = "\\\\t";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}