use strict;
my $str = 'foo: here is some sample text
bar: here is some sample text
The closest that I\'ve gotten has been using this:
';
my $regex = qr/(?m-s)(?:^(?=.*\bbar\b)|(?!^)\G).*?\K[ ]{2}/p;
my $subst = '\\\\t';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";