import re
regex = re.compile(r"(?m-s)(?:^(?=.*\bbar\b)|(?!^)\G).*?\K[ ]{2}")
test_str = ("foo: here is some sample text\n"
"bar: here is some sample text\n\n"
"The closest that I've gotten has been using this:\n")
subst = "\\\\t"
result = regex.sub(subst, test_str)
if result:
print(result)